変数を重ねて呼び出す方法

投稿者:よっしー 投稿日:2018/04/24(Tue) 17:06:14 No.2062

はじめまして。

業務用にプログラムを作成中で
日々コードが短くなるようにリファレンスを見ながら考えて組んでいますが、

先に宣言した変数を繰り返しながら取得する良い方法はないでしょうか
一回ずつ指定すれば取得できると思いますが、1行にまとめたいと考えています。

味選択1は、「ぶどう」
味選択2は、「みかん」
味選択3は、「りんご」
味選択4は、「メロン」
4回、値を1から増やしながら繰り返す
  //味選択1~4を1つの動作で取得したい
  [味選択[値]の内容]を表示 //変数を複数重ねて呼び出す事は不可能?(エラー)
  /* 以下を1行で取得したい
  味選択1の内容を表示
  味選択2の内容を表示
  味選択3の内容を表示
  味選択4の内容を表示
  */
繰り返し終わり

また、変数のようなものに数行のよく繰り返すプログラムを先に宣言してその後に1行で実行させる方法は存在しているのでしょうか。

例:
「Produire.Data.PgSql.dll」を利用する
PostgreSQLというPostgreSQLデータベースを作る
PostgreSQLの接続文字列を「Host=[ホスト];Port=[ポート];Database=[データベース名];User Id=[ユーザー];Password=[パスワード];」に変える
PostgreSQLへ接続する
もしPostgreSQLの状態が「接続済み」でないなら、終了する

データベース接続は、「上の動作を全て呼び出せる」

ボタンがクリックされた時の手順
[データベース接続]
次の手順
終わり

以上2点について、よろしくお願いします。

Re: 変数を重ねて呼び出す方法

投稿者:アーク <info_nds-labo あっとまーくexcite.co.jp> 投稿日:2018/04/25(Wed) 08:47:10 No.2063

よっしーさん、おはようございます。アークです。

〉変数を複数重ねて呼び出す事…
この様な時に普通は配列を使いますがそれでは駄目なのでしょうか。

〉その後に1行で実行させる方法…
これも普通は手順を使いますがそれでは駄目なのでしょうか。

配列や手順を使えない状況が有るのでしょうか。

Re^2: 変数を重ねて呼び出す方法

投稿者:よっしー 投稿日:2018/04/25(Wed) 10:46:18 No.2064

アーク様 おはようございます。
早速のご返答ありがとうございます。

AccessとExcelVBAを使用した旧システムからの新規構築中で
表部品とデータベースを使用した大掛かりなシステムで、
データベースから取得した内容をデータ表として表部品に追加し、
その表部品上で処理を分岐させて内容を変更してエクセルへ出力などしていますので、ややこしくなっています。

配列に代入する事は盲点でした。
ありがとうございます。

配列1は、{}
味選択1は、「ぶどう」
味選択2は、「みかん」
味選択3は、「りんご」
味選択4は、「メロン」
配列1に味選択1を追加
配列1に味選択2を追加
配列1に味選択3を追加
配列1に味選択4を追加
4回、値を1から増やしながら繰り返す
  [配列1の[値]番目の内容]を表示
繰り返し終わり


また、手順の件については以下で解決しそうです。
ありがとうございます。

ボタン1がクリックされた時の手順
  テストする
終わり

テストする手順
  「テスト」を表示
終わり

プロデルの書きやすさや対応範囲の広さに魅力を感じており、
多言語での構築は考えておりません。

特に縛りはありませんがどう再現するか、どう処理するかの際に
まだ完全にプロデルを理解しておりません。
答えが出ない時にまた質問させて頂きますので
その際はよろしくお願いします。

▲ページの先頭へ

- WebForum -