辞書

概要

見出しとそれに対応する値を持つ種類です。

 

生成する方法

辞書定数式を指定すると、生成できます。

値段表は、{りんご=「120円」、バナナ=「80円」、ぶどう=「130円」}

文字列から辞書を生成するには、「辞書化」手順を使います。 

手順

次の手順が使用できます。

削除する 設定する 存在する 得る 

【自分】から【キー】を削除する

キーと同じ要素を削除します

値段表は、{りんご=「120円」、バナナ=「80円」、ぶどう=「130円」}
値段表を表示する
値段表から「バナナ」を消す
値段表を表示する

【キー】へ【内容】を設定する

要素を指定したキーで格納します

値段表は、{りんご=「120円」、バナナ=「80円」、ぶどう=「130円」}
値段表へ「ぶどう」として「230円」を設定する
値段表(「ぶどう」)を表示する

【自分】に【キー】が存在する真偽値

キーが存在するかどうか判定します

値段表は、{りんご=「120円」、バナナ=「80円」、ぶどう=「130円」}
もし値段表に「りんご」が存在するなら
  「あります」を表示する
でなければ
  「ありません」を表示する
もし終わり

【自分】から【キー】を得る:プロデル値

キーと同じ要素を取得します

値段表は、{りんご=「120円」、バナナ=「80円」、ぶどう=「130円」}
[値段表から「バナナ」を得たもの]を表示する

設定項目

次の設定項目が使用できます。

設定項目   説明
内容 文字列 辞書に格納された見出しと内容をすべて文字列として表します
見出し 文字列配列 辞書に格納されたすべての項目の見出しを配列として表します

値段表は、{りんご=「120円」、バナナ=「80円」、ぶどう=「130円」}
値段表の見出しを表示する

個数 整数 辞書に格納された項目の個数を表します

値段表は、{りんご=「120円」、バナナ=「80円」、ぶどう=「130円」}
値段表の個数を表示する

記号の意味

プログラム例

果物の価格表を作成して、バナナの値段を取得します。

値段表は、{りんご=「120円」、バナナ=「80円」、ぶどう=「130円」}
値段表(「バナナ」)を表示する  ーー「80円」と表示されます

食べ物の種類ごとの得点表を作成して、ごはんの得点を取得します。

食べ物の「やさい」は、「100」
食べ物の「さかな」は、「200」
食べ物の「くだもの」は、「120」
食べ物の「ごはん」は、「100」

食べ物の「ごはん」を表示する
食べ物を表示する