プロデルデザイナ

日本語プログラミング言語「プロデル」ワンページ マニュアル


プロデルデザイナとは

プロデルでプログラムを作るには、「プロデルデザイナ」という専用のエディタを使います。
プロデルデザイナには、次の機能が用意されています。

  • プロデルのプログラムを作成、編集する機能
  • ウィンドウのデザイン機能
  • 作成したプログラムを実行、テストする機能
  • 実行可能ファイルへの出力機能

プロデルデザイナの起動方法

セットアッププログラムを利用してインストールした場合は、「スタート」メニューから「プロデル」→「プロデルデザイナ」をクリックします。

Zip形式から解凍した場合は、解凍したフォルダにある「Designer.exe」をクリックします。

プロデルデザイナを起動すると、次のような画面が表示されます。

画面の説明

プログラムは、中央のテキストボックスに入力します。

作成しているプログラムを保存するには、「ファイル」メニューから「上書き保存」をクリックします。

テキスト領域のフォントを変えるなどの設定は、「ツール」メニューの「オプション」で変更できます。

ファイルタブ領域

画面中央の領域には、開いているファイルの内容が表示されます。

ファイルを開く度に、新しいタブが追加され、タブを切り替えることでその名前のファイルの内容を見たり編集できます。

機能タブ領域

プロデルデザイナ画面の右側には、画面右側の機能タブ領域があります。機能タブ領域では、プログラムの編集を補助するための機能が用意されています。

「編集」タブ

プログラムのアウトラインなどプログラムに関する情報を見たり、入力を支援する機能が用意されています。

機能バーの「編集」タブの上側にあるアウトラインには、プログラムに含まれる手順や種類、ウィンドウの一覧が表示されます。
アウトラインの項目をダブルクリックすると、目的の部分へジャンプすることができます。

「機能」タブ

プログラムの入力を支援する機能が用意されています。

「リファレンス」タブ

リファレンスの内容を参照することができます。


プログラムの編集

文字のコピーや貼り付けなどの操作は、「編集」メニューから操作できます。

プログラムで頻繁に使われる記号は、「挿入」メニューから入力できます。

カーソル移動履歴

編集中のカーソルを置いた場所は、プロデルデザイナが記憶しており、必要に応じて前に操作したカーソル位置へ戻ることができます。

定義へ移動

プログラム中の種類や手順、変数が定義されている箇所へ移動することができます。

定義を確認したい箇所にマウスカーソルを置き、右クリックして「定義へ移動」を選択して下さい。

名前の変更

プログラム中の同じ変数の名前を変えることができます。


手順や設定項目を選びながら入力する

プロデルデザイナには、入力中の文字列に合致する、プロデルで使われる種類や手順、設定項目の候補を一覧で表示する機能があります。
この機能を「入力補完機能」といいます。

入力補完機能は、文字を入力中に表示されるほか、[Ctrl]+[スペース]キーを押すことでも、入力候補の一覧が表示されます。

表示された候補から入力したい項目を選ぶと、その項目が自動的に挿入されます。

 

入力補完機能の使い方

1.入力したい字句の書き出し(ひらがなや漢字)で入力します
2.[Ctrl]+[スペース]キーを押します
3.手順や設定項目、変数などの一覧が表示されるので、[↓][↑]で選び、[エンター]キーを押します
4.選択した内容が入力されます

設定項目の選択

動詞の選択

候補表示の意味

表示される候補には、「...」や「》」などの記号が表示される候補があります。

「...」が付いた動詞を選択すると、次にその動詞を持つ手順の候補が表示されます。

「》」が付いた手順を選択すると、その手順に必要な引数が付加されてテキストに入力されます。
手順名だけを入力したい場合は、[Shift]+[Enter]で選択してください。

挿入後の穴埋め

入力補完後に選択した項目によっては、穴埋めするための《 》が表示されます。

入力補完直後は、最初の穴埋め部分が選択されます。
穴埋め箇所は、[Ctrl] + [←]または[Ctrl] + [→]を押すことで、移動できます。

 

入力候補を非表示にする

入力している文字の邪魔になる場合などは、[Ctrl]キーまたはで候補一覧を消すことができます。

常に表示したくない場合は、ツールバーの「入力候補」ボタンのチェックを解除してください。

 

候補の提示タイミングを変更する

プログラムを入力中に、補完機能が候補を表示するタイミングを変更できます。

既定の設定では、漢字確定前(IMEの未確定の状態)に候補一覧が表示されます。

詳しい説明は、「オプション設定」の「入力補完」をご覧ください。

候補が正しく提示されないときは

入力候補は、直前に入力・選択した候補などの状態によって、フィルタリングされることがあります。

提示される候補が思った内容と異なるときや、候補が少ないときは、[Escape]キーを押すことで、初期状態に戻せます。


「ウィンドウの設計」画面

「ウィンドウの設計」画面を使って、プログラム上で表示するウィンドウをデザインすることができます。
マウス操作で、ボタンやテキストボックスなど貼り付け、移動したりすることができます。

 

新規ウィンドウを作成する

右側のアウトラインの上部にあるツールバーから「新しいウィンドウ」ボタンをクリックします。

アウトラインに、「新しいウィンドウ」項目が追加され、名前が指定できます。

追加された項目を、ダブルクリックすると、「ウィンドウの設計」画面が表示されます。

部品を貼り付ける

ウィンドウ上に貼り付ける部品は、「ウィンドウの設計」の左側にある
ツールボックスから選ぶことができます。

ツールボックス

部品を貼り付けるには、次のように操作します。

  1. ツールボックスから部品を選択します。
  2. ウィンドウ上で部品の左上の位置からドラッグして大きさを決めます。
  3. マウスボタンを離すと、その大きさに部品が貼り付けられます。

 

部品の設定を変える

部品の名前や色などを変更するには、プロデルデザイナの右下に表示される「設定項目一覧」を操作します。

ウィンドウ上の部品を選択した状態で、設定項目一覧から変更したい設定項目を選び、内容を変更します。

設定項目によって、選択肢から選ぶことができる場合や、色の選択画面が表示される場合があります。

部品の設定

 

プログラムを出力する

ウィンドウの設計で編集した内容は、プログラムとして出力されます。

ウィンドウの設計画面のタブを閉じると、プログラムを出力されます。

ウィンドウ一つに対して、一つの種類が生成され、必要なプログラムが「初期化する」の手順に生成されます。

出力された「初期化する」手順の内容を「プログラムの編集」画面で、書き換えないでください。
ウィンドウの設計を開くことができなくなったり、書き足したプログラムがすべて消える場合があります。

 

再度、ウィンドウを編集する

再度、ウィンドウを編集するには、プロデルデザイナのアウトラインから、再編集したいウィンドウを選び、ダブルクリックします。
または、再編集したいウィンドウを右クリックして「設計画面を開く」を選びます。

 

イベント手順を作る

1.部品を選択して、右クリックします。

イベント手順の作成

2.コンテキストメニューから「イベント手順の設定」を選びます。

3.作成したいイベント手順を選び、[OK]ボタンをクリックします。

イベント手順の選択

4.選択したイベント手順が作られます。

追加されたイベント手順

注意点

「ウィンドウの設計」画面で設計したウィンドウと、「プログラムの編集」画面のプログラムは、連動しています。プログラム内で作成したウィンドウに該当する部分を削除すると、「ウィンドウの設計」画面のタブが削除されます。


プログラムの情報を得る

「調査ウィンドウ」で、実行中のプログラムの変数の値や呼び出された手順などの情報を調査することができます。

調査ウィンドウは、プロデルデザイナの「ツール」メニュー→「調査ウィンドウ」から開くことができます。

調査ウィンドウには、「対話画面」、「変数」、「呼び出し履歴」の3つのタブがあります。

 

「対話画面」タブ

実行中のプログラムに対して、手順を実行させることができる画面です。また、「報告」命令でプログラムから報告された内容が表示されます。

 

「変数」タブ

実行中のプログラムで使用される変数とその値を確認できる画面です。上部に表示された変数一覧から変数を選択すると、下部に値の内容が表示されます。

変数一覧のアイコンが「+」の場合、公開変数を表し、「-」の場合、手順・種類内限定のローカル変数を表します。

選択した変数が文字列・数値の場合は、下部に値の内容が表示されます。
配列・辞書の場合は、下部にリストが表示されます。
オブジェクトの場合は、下部にツリーが表示され、設定項目や変数の値を確認することができます。

「呼び出し履歴」タブ

実行中のプログラムで現時点で、実行されている手順と、呼び出し元の手順が一覧で表示されます。

一覧をダブルクリックすると、プロデルデザイナで該当部分のプログラムへ移動します。


複数のプログラムを編集する「プロジェクトモード」

複数のプロデルファイルにまたがるプログラムを作成する場合には、プロジェクトモードを使うと便利です。

プロジェクトモードでは、ひとつのプロジェクトに対して、複数のプロデルファイルを扱うことができるようになります。

プロジェクトモードを利用すると次のことが可能になります。

  • 同じプロジェクトの他のプロデルファイルの種類・手順が利用できる
  • バージョン情報の指定ができる
  • プログラムの実行方法を設定できる

 

プロジェクトの作成

プロジェクトを作成するには、「ファイル」メニューから「新規作成」→「プロジェクト」を選びます。

保存先とプロジェクトファイル名を入力して、[保存]ボタンをクリックします。

プロジェクトを作成すると、プロジェクトモードになります。

 

プロジェクトにファイルを追加するには、右側のアウトラインで右クリックして「プロジェクト」から「新規ファイルを追加」または「既存ファイルから追加」を選びます。

プロジェクトモードでは、ファイルのタブを閉じても、アウトラインから再びファイルを開くことができます。

最初に実行するプログラムの指定

プロジェクトモードでは、「実行」ボタンをクリックした際に、最初に実行するプロデルファイルを指定する必要があります。

  1. 最初に実行するプログラムを指定するには、右側のアウトラインを使います。
  2. アウトラインから指定したいプロデルファイルを選択して、右クリックします。
  3. メニューの「最初に実行する」をクリックします。
  4. アウトラインの指定したプロデルファイルに下線が表示されます。
  5. この状態で、「実行」ボタンまたは「実行」メニューを操作すると、下線があるプロデルファイルが実行されます。

 

プログラムの実行方法の設定

プロジェクトモードでは、「実行」ボタンをクリックした際に、実行する方法を選ぶことができます。

実行方法を選ぶには、「プロジェクト」メニューの「詳細設定」を選びます。

詳細設定の「プログラム実行」タブ

プロデルデザイナ上で実行する
プロデルデザイナ上でプログラムを実行します。
「調査ウィンドウ」や停止行の設定などの機能が利用できます。
コンソール上で実行する
コマンドプロンプト画面上でプログラムを実行します。
「調査ウィンドウ」や停止行の設定などの機能は、利用できません。
また、実行するプログラムは、コンソール向けに作成する必要があります。
別プロセスで実行する
エクスプローラで直接プロデルファイルを開いた場合と同様に、
プロデルデザイナとは、別のプロセスで実行します。
「調査ウィンドウ」や停止行の設定などの機能は、利用できません。
特定のプログラムを実行するまたはファイルを開く
プログラムを実行する操作をした際に、指定したプログラムを起動したり、指定したファイルを開いたりします。
この方法を選んだ場合は、「位置」でプログラムまたはファイルを指定する必要があります。
「調査ウィンドウ」や停止行の設定などの機能は、利用できません。
Webサーバ上で実行する
プログラムを実行する操作をした際に、指定したURLを開きます。
プロデル簡易Webサーバを使用した場合に利用します。

「調査ウィンドウ」や停止行の設定などの機能は、利用できません。

プロジェクトの詳細設定

プロジェクトモードの場合、「プロジェクト」メニューが表示されます。

「プロジェクト」メニューの「詳細設定」では、実行可能ファイルを作成する際に使用するバージョン情報を指定することができます。

詳しくは、実行可能ファイルの作成をご覧ください。


実行可能ファイルを作成する

作成したプロデルのプログラムから、プロデルがインストールされていない環境でも実行できる形式(実行可能ファイル)を作成することができます。

作成された実行可能ファイルは、Windows98以降の.NET Framework2.0がインストールされた環境で動作します。

作成する方法

1.「ファイル」メニューから「実行可能ファイルの作成」を選びます。
または、ツールバーから「実行可能ファイルの作成」ボタンをクリックします。

実行可能ファイルの作成

2.実行可能ファイルのファイル名を指定して、[保存]をクリックします。

実行可能ファイルの種類

プロデルデザイナでは、次の形式で作成できます。

種類 説明
実行可能ファイル Windowsデスクトップアプリケーションとして生成します。
プロデルプラグイン プロデルプラグインとして生成します。プログラムで宣言された種類が対象となります。
実行可能ファイル(コンソール) コマンドプロンプト上で実行する実行可能ファイルを生成します。
コンパイル済み実行可能ファイル コンパイル済みのデスクトップアプリケーションとして実行可能ファイルを生成します。
コンパイル済み実行可能ファイル(コンソール) コンパイル済みのコンソールアプリケーションとして実行可能ファイルを生成します。

アイコンを指定する

実行可能ファイルには、独自のアイコンを指定することができます。
対応しているアイコン形式は、アルファチャネルやVista形式を含め、ほとんどの形式に対応しています。

なおアイコンを作成するには、Visual Studioやアイコン作成・変換フリーソフトを利用して下さい。

単一のプロデルファイルの場合

実行可能ファイルに独自のアイコンを指定する場合は、作成したプロデルのプログラムのファイル名と同じフォルダに同じ名前のアイコンを置いてください。

例えば、実行可能ファイルを作成したいプロデルファイルが、「アプリ.rdr」の場合
独自アイコンは、同じフォルダに「アプリ.ico」という名前で、置きます。

プロジェクトモードの場合

プロジェクトモードの場合は、「プロジェクトの詳細設定」画面で設定することができます。

アイコンの設定

 

バージョン情報を指定する方法

実行可能ファイルに、プログラムの概要やバージョン、著作権情報を指定することができます。

バージョン情報を指定するには、作成したいプロデルファイルがプロジェクトモードである必要があります。

設定方法

1.プロジェクトファイルを開いた状態で、「プロジェクト」メニューから「詳細設定」を選択します。

2.「プロジェクトの詳細設定」画面で、「詳細情報」のリストから編集したい項目を選び、
内容を右側へ入力します。

3.[OK]ボタンをクリックした後、「ファイル」メニューの「実行可能ファイルの作成」で、
実行可能ファイルを作成すると、バージョン情報が含まれた実行可能ファイルが作成されます。

ファイルの同梱

素材ファイルの同梱

画像ファイルや効果音などプログラム中で使用する外部ファイルを、素材として実行可能ファイルの作成時に同梱できます。

「素材として利用する」文に指定されたファイルが実行可能ファイルに埋め込まれます。

例えば、「タイトル.png」というファイルを実行可能ファイルに埋め込むには、次のように書きます。

「タイトル.png」を素材として利用する

素材として利用するファイルは、「素材リスト」種類を使ってプログラム中で利用できます。

また、素材は、アウトラインから追加・削除することもできます。

プラグインの同梱

プログラム中でプラグインの機能を利用している場合は、通常、実行可能ファイルの作成時にプラグインが同梱されます。

既定値では、プログラム中で使用している種類が含まれるプラグインを同梱しますが、オプションによってこれらのプラグインを同梱しないように設定できます。

作成される実行可能ファイルについて

作成される実行可能ファイルは、.NET Framework 4/2.0上で動作するプログラムが生成されます。

プロデルは、.NET Framework 4用と2.0用があり、作成させる実行可能ファイルはそのバージョンに応じたバージョンとなります。

Windows 7またはVistaでは、作成された実行ファイルを配布するだけで、
プロデルがインストールされていない環境でも、実行可能です。

.NET Framework 2.0版の場合は、Windows XPなどWindows 98以降のWindowsで
.NET Framework 2.0をインストールされた環境であれば、実行できます。

実行可能ファイルには、作成したプログラムとプロデルランタイムが含まれた形で生成されます。

コンパイル済み実行可能ファイル

プロデルプログラムをコンパイルして実行可能ファイルして生成できます。コンパイルした場合は、通常のインタプリタ版の実行可能ファイルに比べて繰り返し処理や配列の処理の速度が高速になります。

注意点

コンパイルした場合でも.NET Frameworkのクラスライブラリは使用されず、プロデル標準機能やプロデルプラグインの機能が利用されます。また直接、中間コードが生成されるため、C#やVB.NETなどの他のプログラミング言語のコードへ変換することはできません。


「オプション」画面

「オプション」画面で、プロデルデザイナの画面設定やプロデルの動作設定を変更することができます。

「オプション」画面

テキスト領域

プログラムを編集するためのテキストボックス(テキスト領域)についての設定を変更します。

フォント

プログラムの字体や文字の大きさ、色を変更します。
[フォントの変更]ボタンで、字体や文字の大きさを変更することができます。
[既定]ボタンで、設定を初期状態に戻すことができます。

プログラムに色を付ける

プログラムの構文に応じて、文字に色を付ける(ハイライト表示する)かどうかを設定します。

行番号を表示する

テキスト領域の左側に行番号(ルーラ)を表示するかどうかを設定します。

選択した部分をマウスで移動できるようにする

選択した部分のプログラムをドラッグ&ドロップ操作で移動できるようにするかどうかを設定します。

画面

一覧表示

アウトラインやリストで表示する字体や文字の大きさを設定します。

プログラム

プログラムの保存

エンコード

新しくプログラムを保存する際の文字コードを選択します。
ただし、すでにあるファイルを開いて、変更を保存した場合、
保存する前と同じ、文字コードで保存されます。

コメント記号

コメントとして使用する記号を選択します。

自動的にこのコメント記号に置き換える

開いたプログラムのすべてのコメントについて、ここで設定した記号に置き換えるかどうかを設定します。

プロデルデザイナ

起動時

起動時に新規ファイルを作成する

プロデルデザイナを起動した際に、あらかじめ新規ファイルを開いた状態にするか動画を設定します。

前回最後に開いたファイルを開く

プロデルデザイナを起動時に、前回プロデルデザイナを終了した際に開いたファイルを開きます。

その他

[関連付けする]/[関連付けしない]

エクスプローラなどでプロデルファイル(*.rdr,*.プロデル;*.rdrproj)をダブルクリックした際に、
プロデルデザイナを起動するかどうかを設定します。

Windows Vista/7で設定を反映させるには、プロデルデザイナを管理者権限で起動する必要があります。

最近利用したファイルの表示数

「ファイル」メニューの「最近使ったファイル」メニューに表示する開いたファイルの履歴数を設定します。

入力補完

入力補完機能で候補一覧を表示するタイミングなどを設定します。

入力補完を有効にする

自動的に入力補完候補を表示するかどうかを設定します。
このチェックが解除されている場合でも、[Ctrl] + [スペース]で候補を表示することができます。

補完候補の表示タイミング

文字を入力中に、入力補完候補を表示するタイミングを設定します。
この設定は、IMEで文字を入力する際に適用されます。

漢字確定前・・・IME上でひらがなを入力中(未確定状態)の時から、候補一覧を表示します。
漢字確定後・・・IMEでかな漢字変換した文字を確定した直後に、候補一覧を表示します。


単体テストツール(RdrUnit)

プロデル テストツールとは、プロデルで作成したプログラムが正常に動作するかどうかを
チェックするための単体テスト支援ツールです。

プロデルでプログラムを作成した上で、そのプログラムが正しく動作するかどうかを確認するテストケースを作成し、テストツールを使って、テストケースを自動的にチェックすることができます。

プロデルデザイナには、単体テストツールとしてRdrUnitが用意されています。

 

テストケースの作成

テストツールを使ってプログラムをテストするために、テストケースを作成します。
テストケースは、プロデルのプログラムで作成します。

テストケースを作成するためには、プロデルプログラムに「テストケース」種類を継承した種類を用意します。
「テストケース」種類は、サンプル→ソフト開発→テストツール→「プロデルテストユニット.rdr」を参照することで利用できます。

テストケース種類を継承した種類に、テスト内容を書いた手順を書きます。
手順をテストの対象とするには、手順名定義の直後に「※テスト」と書きます。

「プロデルテストユニット.rdr」を参照する

テストとは
  テストケースを継承する

  テストする手順
    ※テスト
    値は、10*10
    値が100と等しいはず
  終わり
終わり

 

テストツールの起動

プロデルデザイナから、テストツールを起動します。

RdrUnitの起動

[テスト]ボタンをクリックすると、現在開いているプロデルプログラムから
テストの対象となる手順を探して、テストを行います。

テストが成功すると、次のような画面が表示されます。

テストが成功したとき

テストが一つでも失敗すると、次のような画面が表示されます。

テストが失敗したとき

 

テストケースで使用できる手順

テストケースでチェックする項目の判定は、
プロデルで書かれた「テストケース」種類の中にある手順を使います。

「テストケース」種類には、次のような手順が用意されています。

〈[テスト内容]として〉【値:真偽値】が正しいはずかどうか

値が真(○)のとき、テストが成功したと判定されます。

「成功するテスト」として○が正しいはず
「失敗するテスト」として×が正しいはず

〈[テスト内容]として〉【値1】が【値2】と等しいはずかどうか

値1が値2と等しいとき、テストが成功したと判定されます。

「成功するテスト」として10*10が100と等しいはず
「失敗するテスト」として10+10が100と等しいはず

〈[テスト内容]として〉【値1】が【値2】と異なるはずかどうか

値1が値2と異なるとき、テストが成功したと判定されます。

「成功するテスト」として10*10が20と異なるはず
「失敗するテスト」として10+10が20と異なるはず

〈[テスト内容]として〉【値】が無であるはずかどうか

値が無であるとき、テストが成功したと判定されます。

「成功するテスト」として無が無であるはず
「失敗するテスト」として(ウィンドウを作ったもの)が無であるはず

〈[テスト内容]として〉【値】が無でないはずかどうか

値が無でないとき、テストが成功したと判定されます。

「成功するテスト」として(ウィンドウを作ったもの)が無でないはず
「失敗するテスト」として無が無でないはず

〈[テスト内容]として〉失敗させる

無条件にテストが失敗したと判定されます。

「失敗するテスト」として失敗させる


ドキュメント生成ツール(RdrDoc)

プロデル ドキュメント生成ツールとは、プロデルで作成したプログラムから
種類や手順の使い方が書かれたHTML形式のドキュメントを生成するツールです。

プロデルでプログラムを作成した上で、種類や手順に注釈(アノテーション)を加えることで、
その注釈を使ってドキュメントを生成します。

プロデルデザイナには、ドキュメント生成ツールとしてRdrDocが用意されています。

 

ドキュメント生成用の注釈の作成

ドキュメント生成ツールで出力する説明文は、プロデルプログラムに注釈として指定します。

注釈の例

航空便管理処理とは
※説明 航空便を管理するクラスです。
※作成者 管理システム開発チーム
※バージョン 1.1


  +【自分】へ、【航空便情報】で、航空便を、登録する手順
  ※説明 航空便を登録します。
  ※引数 航空便情報 登録する航空便情報


  終わり
終わり

 

ドキュメント生成に使用する注釈

ドキュメントに出力する説明には、次の注釈を使うことができます。

注釈 意味
※説明 種類、手順および変数の説明
※引数 引数の説明
※戻り値 戻り値の説明
※例文 手順の使用例
※例外 手順で発生する例外
※バージョン 種類、手順および変数のバージョン
※作成者 種類、手順および変数の作成者

ドキュメント生成ツールの起動

プロデルデザイナの「ツール」タブから、ドキュメント生成ツールを起動します。

ドキュメントを生成したいプロデルプログラムをドラッグ&ドロップします。

プロデルプログラムがあるフォルダにHTMLファイルが生成されます。

 

PAGE TOP